?

Log in

No account? Create an account

anatomy · of · distance


PC woes

Recent Entries · Archive · Friends · Profile

* * *
My Linux box appears to not be working properly.


It works well enough most of the time, except that various programs randomly segfault and die. Firefox will die after a few hours (regardless of activity); video transcoding processes will segfault before they're finished, and the XAnalogTV screensaver dies with a SIGABRT or similar whenever it runs. Otherwise, it works OK.

This has been going on for a few weeks; at first, I thought it was one of the memory modules (I upgraded it to 512Mb shortly before the problem started). I tried the machine with only one memory module (and I tried both of them separately), but the same problem happened.

Then I thought it could be the CPU. So I went and bought a secondhand Athlon XP 2000 at CeX on TCR. No dice; the same problem.

(The new CPU also only runs with a core frequency of 100MHz and a 12.5% multiplier, which makes it slower than the Sempron 2600 I used before; and from the 1.7GHz speed cited on the label, it looks like I'm underclocking it. If I run it at 133MHz, the video transcoding test dies in a minute, rather than a few hours, and other things die as well, often crashing the machine.)

At this point I'm not sure what the problem could be. A software bug in the latest Debian libraries? (A few apt-get upgrade cycles did nothing to fix it.) A dodgy motherboard? (Hope not; that'd be a pain to take back.) A bad power supply? (Unlikely; I put in a brand-new Tagan power supply a few months ago.) Heat issues? (My room does get hot, but the machine itself is tricked out with large numbers of fans.)

If anyone else has had this problem, any pointers would be appreciated.
* * *
* * *
[User Picture]
On May 30th, 2005 08:34 am (UTC), kineticfactory commented:
I do have a new PSU; I bought one (a Tagan low-noise one) with the new mobo/CPU a few months ago.
Replies Frozen · Parent · Thread
* * *

Previous Entry · Share · Next Entry